image Adobe suspends 64bit pre alpha Flash plugin for Linux

Bad news for users of 64bit Linux distros: Adobe has pulled all downloads for the existing pre-alpha release of its Flash plugin, citing significant architectural changes and security updates as main contributing factors. 

Read on to find out more

image Adobe suspends 64bit pre alpha Flash plugin for Linux

When it comes to software, Linux users often receive little love from most commercial software makers, and we don’t need to look further than Adobe Flash for evidence supporting such a claim.

For those who are not familiar, Linux was the first OS which introduced native 64bit computing to the masses almost as far back as seven years, when AMD introduced the first x64 processors to the market. And to avoid unneccessary software bloat, mantainers usually chose to either focus development efforts on the original 32bit OS, or provide an additional, purely 64bit version with none of the 32bit runtime libraries bundled within it, effectively cutting off all forms of backward compatibility between 32bit and 64bit applications.

Needless to say, the early adopters who opted for the x64 versions of the distro had to contend with surfing the internet without any form of Flash support, as the lack of 32bit system libraries meant that no 32bit applications could be executed on the OS at all.

To solve this issue, numerous workarounds were implemented; some distros added in a minimal set of 32bit libraries alongside the 64bit versions to enable the execution of 32bit applications such as web browers alongside their 64bit counterparts, some turned to the open-source Gnash plugin for their Flash needs, while others attempted to make use of a wrapper known as nspluginwrapper to ‘wrap’ the 32bit Flash plugin with a 64bit compatibility layer, thus tricking the 64bit web browser into thinking that it is running a 64bit version of Flash. However, such workarounds were not always perfect, and numerous problems have been reported in various message boards about the 32bit Flash plugin crashing the browser outright regardless of the method used, and Gnash had not been able to keep up with Adobe’s progress, being only able to emulate instructions up to version 9 of Flash.

To address these issues, Adobe released a preview x64 version of Flash for Linux which completely eliminated the need to resort to such workarounds, and for a couple of years, x64 Linux users were able to enjoy the same web browsing experience as their Windows, OS X and 32bit Linux counterparts.

Unfortunately, that relief is short-lived, for Adobe has recently announced on the Adobe Labs page that development and testing of the x64 Flash plugin has been suspended in light of “significant architectural changes to the 64-bit Linux Flash Player and additional security enhancements”, as shown in the screenshot below.

flashdelay Adobe suspends 64bit pre alpha Flash plugin for Linux

Needless to say, such a decision is probably not going to be well-received by the Linux community, especially when one takes into consideration that the x64 plugin for Linux had not seen any significant updates during its short two-year lifespan other than the occasional refresh. And with even more web browsers making x64 builds of their client available for download for all major operating systems, demands for a proper, working 64bit version of Flash is only going to increase, and such a move casts a huge shadow over Adobe’s commitment to providing a cross-platform solution for online interactivity in light of HTML5′s hype of ushering in a open web which is not dominated by proprietary standards.

However, there is a glitter of hope left for those who still crave for x64 Flash: Adobe claims that the project is far from dead and insists that they still remain committed to providing a cross-platform x64 Flash plugin” in an upcoming major release of Flash player”. That would have sounded great and all, if they haven’t been promising the same thing more than two years ago.

Meanwhile, if you are an x64 Linux user who needs your daily Youtube fix, there’s always WebM and H.264, with the latter only available via Google’s Chrome browser. That, or you could (and should) make an archive of the x64 Flash plugin Linux if you have it installed in your distro.